No text when inputting on IgeUITextBox

Post your help queries and engine programming questions here

No text when inputting on IgeUITextBox

Postby Zacky » Thu Oct 20, 2016 10:00 pm

@Edit
Finally found solution.
value was changed correctly, but the color was still unneeded changed.
To solve it, just comment line 189 from IgeUiTextBox.js (ige engine)
//this._fontEntity.color(this._color);


Hi everyone,
I'm making multiplayer game based on Isogenic Game Engine and I have a problem with IgeUITextBox.
I tried to make everything like in "5 – Advanced UI System Introduction" tutorial and I see nothing in TextBox when I writting something inside it.
Unlike in the tutorial...

My part of code (same as in tutorial) :


Code: Select all
                  tx1 = new IgeUiTextBox()
                            .id('tx1')
                            .styleClass('myStyle')
                            .mount(ige.$('div1'));

                        tx1._fontEntity
                            .nativeFont('Verdana 10px')
                            .colorOverlay('#ffff00');


I modified tx1 to put value and it's shown corretly. So maybe it's a kind of mistake with text inputing.
Code: Select all
                        tx1 = new IgeUiTextBox()
                            .id('tx1')
                            .value('some text')
                            .styleClass('myStyle')
                            .mount(ige.$('div1'));


Please help me,
thank you in advance.
Lukas
Zacky
 
Posts: 1
Joined: Thu Oct 20, 2016 9:53 pm

Return to Help & Questions

Who is online

Users browsing this forum: No registered users and 1 guest
cron